Just a second...

Python

The Python API can be installed using pip and is also included in the server installation.

Note: This limited preview version of the Python SDK is not supported for production use. The API is likely to change for the full release of Diffusion™ 6.6

Install with pip:

pip install diffusion
To install a specific version:
pip install diffusion==6.6rc1
Supported interpreters:
  • CPython 3.7.8 (or later patch release)
  • CPython 3.8.6 (or later patch release)

Future releases will be tested against additional interpreters.

We recommend using the newest available patch release.

Capabilities

This preview version of the Python SDK supports a limited subset of Diffusion features.

Currently it can subscribe to topics, but not create or update them. It also supports request-response messaging.

The full 6.6 version is planned to implement support for more functions.

See the API documentation for details.

Resources